Resource Menu


posted by Robert Albarran at Apr 25, 2013 7:21 PM
Quote
Thank you very much!

Do you know a good place to reference the mathematical modeling methods used in the SPIS solvers?

Thanks again! Robert

posted by Benoit Thiebault at Apr 16, 2013 4:30 PM
Quote
I don't have an answer for this question

Maybe SPIS-NUM developers can answer.

In theory, I don't think there should be any problem with this density.

Check the debug.log file for stacktraces or silent crashes. You can also check your memory usage: if it is higher than the amount Java is allocated, it can crash (sometimes silently).

Another tip: if you want to increase the memory allocated to your SPIS execution, you can edit the launch script with a text editor (SpisGeo.sh or SpisGeo.bat). Replace all occurrences of -Xmx1024M with the appropriate value (1024M stands for 1024 Mb of RAM).

Kind regards,

Benoît

posted by Robert Albarran at Apr 16, 2013 6:24 AM
Quote
    • ion and electron density of 1E12 m^-3, that is.
posted by Robert Albarran at Apr 16, 2013 6:23 AM
Quote
It seems to not begin the simulation when I choose the ion and electron density to be 1E12. Is this too high? Thanks a million!

posted by Robert Albarran at Apr 16, 2013 6:19 AM
Quote
Hi Benoit,

Thank you for your input. I will be working with the geoCasselll.geo geometry until I get mine to work; I have produced two simulations with it. Thank you! With these runs, I noticed that sometimes the simulation takes a very long time to begin. Is there any way to make them run faster?

Thanks again! Robert

posted by Benoit Thiebault at Apr 12, 2013 9:43 AM
Quote
Hi Robert,

There seem to be a problem with your mesh (degenerated tetrahedra?). Try to modify the resolution of the mesh or to use optimized meshing parameters in Gmsh (see Gmsh user manual).

In SPIS 5, you can now import meshes directly in the mesh editor (skipping the geometry editor step). So if you want, you can launch Gmsh, set the optimized parameters that suit your project, mesh it in 3D and save the mesh file. Then launch SPIS and import the generated mesh directly.

Kind regards,

Benoît

posted by Robert Albarran at Apr 11, 2013 7:00 PM
Quote
Hi, here is a copy of the last bug file. I have a feeling the problem lies in my geometry, however, everything goes well until the simulation. Please let me know what you think. Thanks a bunch!! Robert

[Edited by moderators] debug.log

posted by Benoit Thiebault at Apr 11, 2013 9:07 AM
Quote
Why is a good question

Each time SPIS is launched, it creates a debug.log file in the installation folder. This file contains a lot of debug-level information that can help us find the origin of your problem.

The file is overridden at each launch of SPIS, so if you did not restart SPIS since last crash, you can send us this file. Otherwise, you should restart SPIS, make the bug appear again and then submit the debug.log file.

Kind regards,

Benoît

posted by Robert Albarran at Apr 10, 2013 6:20 PM
Quote
When I enter the global parameters and click on finalize run configuration and save project, it does not give me any errors. However, it does not proceed to the simulation task. Do you know why?

Thank you very much

posted by Robert Albarran at Apr 9, 2013 6:37 PM
Quote
Hi Julien,

Thank you for your help. I have downloaded SPIS 5.0 and am at the data mining step now. (I used the same gmsh text file that I used in SPIS 4.3.1) To visualize the data after entering global parameters, I exported the categories such as surface potentials, trajectories etc… to my project folder. If it worked this far, am I on the right track? How can I view animations and other data representations?

Thanks again for your help!! Robert

posted by julien at Apr 9, 2013 8:50 AM
Quote
Dear Robert,

First of all, as Benoit already explained, we deeply recommand to use the last release (SPIS 5.xx) where most of these difficulties are solved or at least reduced.

Second, regarding your message, this may have several reasons, by de-creasing order of importance/relevance:

1- The produced mesh is degenerated or malformed, probably due to an incorrect geometrical definition and/or a mesh not refined enough. Check this and eventually refine you mesh and/or simplify your geometrical model.

1- If you use "thin wire models", you did not set properly the S/C propertie on this group. Actually, edge radius is not really taken into account in such model in SPIS-Legacy (i.e 4.3 and older).

1- You forgot or improperly set a properties/groups, especially on the S/C surface.

Hard to say more without more information. And one more time, we recommand to use SPIS 5.0 in place of the previous versions. Projects migration should be doen carefully but is possible.

Best regards,

Julien.

posted by Robert Albarran at Apr 9, 2013 5:27 AM
Quote
Any ideas of how to solve this would be vastly appreciated.

Could it be an error in the geometry or in the global parameters?

It seems the geometry was able to go through the mesh group conversions and even the UI to NUM process was successful. What could go wrong?

Thanks again

posted by Robert Albarran at Apr 7, 2013 6:59 AM
Quote
Hi, Thank you very much for your time. Please find below the content of the Logging in the solver where the error occurs.

INFO ! JyTop4 ! - JyTop initialised INFO ! JyTop4 ! - Initialisation of simulation Nb:20134742326 INFO ! JyTop4 ! - SPIS/NUM main is under creation INFO ! JyTop4 ! - creation of the ThreeDUnstructSurfMesh structure (for SC surface) EDGE RADIUS LENGTH = 249 INFO ! JyTop4 ! - creation of the ThreeDUnstructSurfMesh structure (for external boundary surface) WARNING: EDGE RADIUS ARRAY = NULL INFO ! JyTop4 ! - creation of the ThreeDUnstructVolMesh structure (for Plasma Volume) CAUGHT EXCEPTION AT VOLUME MESH CONSTRUCTION => NOT GOOD!!

Please let me know if this helps. Thanks again for your time! Sincerely

posted by Benoit Thiebault at Apr 5, 2013 10:54 AM
Quote
First of all, we recommend you to use SPIS 5.0.1 that is available on the download page.

A lot of things have been improved/corrected in this version and we don't provide support for 4.3.1 version anymore.

Regarding your error, we would also need more information (copy/paste of the content of the console) to understand exactly what the problem is. An array index out of bounds exception can come from many various reasons. Basically, it says that an array does not have the correct size.

Kind regards

posted by Robert Albarran at Apr 5, 2013 8:53 AM
Quote
suggestions?
posted by Robert Albarran at Apr 4, 2013 5:46 PM
Quote
Hi, I am using SPIS release 4.3.1

Thanks!

posted by Benoit Thiebault at Apr 3, 2013 11:22 PM
Quote
What is the version of SPIS you are using?
posted by Robert Albarran at Apr 3, 2013 9:55 PM
Quote
When calling the solver task, I get a ERROR IN SIMULATION THREAD that says java.lang.ArrayIndexOutOfBoundsException

What does this mean and how may I solve it? Thanks!