Resource Menu


posted by Sébastien Hess at Dec 19, 2018 3:20 PM
Quote
Hello,

the error you get comes from the Poisson solver. Apparently it fails to invert the Poisson matrix. Can you check the quality of your mesh? Some quality factors should appear in the initialization popup.

Best Regards,

Sébastien

posted by Hodong Lee at Dec 11, 2018 9:36 AM
Quote
Oh, I omitted some sentence. The following is the particle distribution settings that I have assigned.

Pop 0 is ions1(O+) : type PICVolDistrib

-> with density 9.9999998E10m-3

-> with temperature 1.0eV

Pop 1 is elec1(electron) : type PICVolDistrib

-> with density 9.9999998E10m-3

-> with temperature 0.2eV

Pop 2 is Thruster0_1_Xe+(Xe+) : type PICVolDistrib

Pop 3 is Thruster0_2_Xe(Xe) : type PICVolDistribWithSpeedUp

Pop 4 is Thruster0_3_Xe++(Xe++) : type PICVolDistrib

Pop 5 is Thruster0_4_Xe+(Xe+) : type PICVolDistrib

Pop 6 is Thruster0Electrons(electron) : type electric_propulsion.SPT100CathodeElectronModel

I wonder if I can fix this error by adjusting the global parameter.

I look forward to your reply.

Thank you.

posted by Hodong Lee at Dec 11, 2018 9:26 AM
Quote
Hello. I managed to reach the simulation step.

However, when I tried to launch simulation, the following error continuously occurred in Log console:

INFO s.U.i.SpisIO ! SpisIO.java:372 ! ERROR in LDLt decomposition in assembPrecontNonLinear =(some number...)

I am using SPIS-Propulsion-6.0.0-win64b.

Geometry that I made is a small box satellite, and the top of the satellite has a small circle which corresponds to the thrust exit plane.

Pop 0 is ions1(O+) : type PICVolDistrib

-> with density 9.9999998E10m-3

-> with temperature 1.0eV

Pop 1 is elec1(electron) : type PICVolDistrib

-> with density 9.9999998E10m-3

-> with temperature 0.2eV

Pop 2 is Thruster0_1_Xe+(Xe+) : type PICVolDistrib

Pop 3 is Thruster0_2_Xe(Xe) : type PICVolDistribWithSpeedUp

Pop 4 is Thruster0_3_Xe++(Xe++) : type PICVolDistrib

Pop 5 is Thruster0_4_Xe+(Xe+) : type PICVolDistrib

Pop 6 is Thruster0Electrons(electron) : type electric_propulsion.SPT100CathodeElectronModel

-> with density 1.4395545E16m-3

-> with temperature 5.0eV

Is this because of the wrong global parameter setting?

Thank you.