Resource Menu


posted by Hodong Lee at Dec 11, 2018 9:29 AM
Quote
Dear Sébastien,

I managed to solve this problem.

The mesh corresponding to ESN 2 was connected to the mesh corresponding to ESN 0. (sharing line)

So, I deleted 'V 0 2 -20' in the circuit definition, and the error did not occur.

Thank you.

Hodong

posted by Hodong Lee at Dec 6, 2018 11:56 AM
Quote
Dear Sébastien,

Thank you for your quick reply.

My Gmsh geometry consists of the following groups: four face group: satellite (body), solar panels, thruster exit plane, and external computational boundary one volume group: Computational volume between satellite(including panels) and external boundary.

So, there are three electrical nodes: Node 0(ground, satellite faces), Node 1: (Solar Panels), Node 2:(Thruster exit plane)

Without any prior knowledge about electrical scheme of thruster, I just wanted to do a quick-start. So, I wrote the circuit definition simply as follows: V 0 1 0 V 0 2 -20

I thought this simple and temporary circuit definition would not cause any problem because I succeeded in performing simulation before with the circuit definition using a very simple test geometry.

I want to ask if the error message can occur because of the poor pre-simulation process like poor geometry / group properties assignment / setting parameter.

I will look forward to hearing from you.

Best regards,

Hodong

posted by Sébastien Hess at Dec 6, 2018 10:35 AM
Quote
Dear Hodong,

I guess you are using SPIS v6.0.0? I am sorry this error occurred without a more explicit feedback. An error at this stage usually means an error in the circuit definition. Do you have one defined?

Best regards,

Sebastien

posted by Hodong Lee at Dec 6, 2018 9:28 AM
Quote
Hello. I am trying to analyze a plume effect of thruster using SPIS-Electrical-Propulsion. Geometry and mesh were created without an error, and I wanted to do a quick-start by using pre-defined global parameters. However, the following error occurred. Even though I changed the global parameters to another, (e.g. LEO, NASA Worst Case, etc....) this problem could not be fixed.

The following is the error message: Ooops! There was an error while initializing the numerical kernel. Please report it to the development team or on SPIS bug tracker. Do not forget to include the debug.txt file at the root of the software. Stacktrace: spis.Util.Exception.SpisRuntimeException: Exception at spis.Top.SC.RLCSC instantiation at spis.Util.io.Introspection.getUIDefinedInstance(Introspection.java:177) at spis.Top.Simulation.SimulationFromUIParams.initSC(SimulationFromUIParams.java:1197) at spis.Top.Simulation.SimulationFromUIParams.init(SimulationFromUIParams.java:450) at spis.Top.Simulation.SimulationFromUIParams.<init>(SimulationFromUIParams.java:343) at spis.Top.Top.Scenario.<init>(Scenario.java:142) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) at java.lang.reflect.Constructor.newInstance(Constructor.java:422) at spis.Util.io.Introspection.getUIDefinedInstance(Introspection.java:161) at spis.Top.Top.NumTopFromUI.<init>(NumTopFromUI.java:135) at org.spis.ui.spis.num.numerical.core.implementation.NumericalCore.<init>(NumericalCore.java:127) at org.spis.ui.ui2num.util.Ui2Num.buildNumTopFromUI(Ui2Num.java:463) at org.spis.ui.ui2num.command.NumTopFromUICommand.run(NumTopFromUICommand.java:170) at org.spis.ui.ui2num.command.NumTopFromUICommand.run(NumTopFromUICommand.java:54) at org.keridwen.core.messaging.AbstractCommand.execute(AbstractCommand.java:208) at org.keridwen.core.messaging.DefaultBundleController$CallableCommand.call(DefaultBundleController.java:267) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745)

How can I fix this problem?

Thank you.