Resource Menu


posted by Arnaud Trouche at Mar 27, 2018 10:44 AM
Quote
Hi everyone,

We have discovered an issue with one of the libraries used by SPIS on some modern systems that impacts the tessellation operation in the Geometry editor.

Some modern Linux OS like Fedora 26 and above have a new version of the libgfortran system library. This version is incompatible with the current version of the jblas library shipped with SPIS.

Thus, the tessellation operation in the Geometry Editor does not work properly on these systems.

A workaround to fix this problem consists in installing an old version of the libgfortran library as indicated on this thread. To do so,

  • find and download libgfortran version 6, you can use sites like rpmfind. You can find the correct version of libgfortran for Fedora here.
  • install it on your system (see the example below for Fedora systems)
sudo rpm -ihv --nodeps --force libgfortran-6.2.1-2.fc25.x86_64.rpm

It should now work directly, and according to our tests, other applications on your system will continue to use the latest version of libgfortran.

Arnaud Trouche